Jump to content
ARMA 3 TvT TOURNAMENT Read more... ×

Don't update to Teamspeak 3.2.x

This announcement is no longer active

NeilZar

As there are currently issues with Teamspeak 3.2.x and TFAR/ACRE causing constant crashing, we will not be updating our server to that version at this time. We advise everyone to downgrade back to 3.1.x until the issue has been solved. (If you updated of course)

  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy